Post a new topicPost a reply Page 1 of 1   [ 3 posts ]
Author Message
 Post subject: Stuck on calculating lights on linux demo
PostPosted: Fri 02 Jun 2017, 23:22 
Mortal

Joined: Fri 02 Jun 2017, 22:55
Posts: 1
Hi! Anxious to try out the game, I loved the original GTA games as a kid. The linux version is bugging me, tho (pun intended). The screenshot is in the attachment. This happens with both the integrated and the discrete graphics card.

Here are the last few log lines:
Code:
Reserving Tile Size: 89600
Buffer Size: 1112278
2017-06-03 00:16:54: Assigning Tile Properties
2017-06-03 00:16:54: Padding Tile Properties
2017-06-03 00:16:54: LOADING MAP: preparing logical elements
2017-06-03 00:16:54: Light Phases: 1
2017-06-03 00:16:54: LOADING MAP: Generating Tile Geometry
2017-06-03 00:16:54: LOADING MAP: Generating Hiding Spots
2017-06-03 00:16:54: Restarting Match
2017-06-03 00:16:54: Not good to go: No Vertex Data
2017-06-03 00:16:55: LOADING MAP: Mapping Textures
2017-06-03 00:16:55: LOADING MAP: Mapping Specularity
2017-06-03 00:16:55: LOADING MAP: Calculating Ambience
2017-06-03 00:16:55: LOADING MAP: Calculating Ambience 2
2017-06-03 00:16:57: LOADING MAP: Calculating Ambience End 1
2017-06-03 00:16:57: LOADING MAP: Smoothing Ambience
2017-06-03 00:16:57: Creating Shadow Rects
2017-06-03 00:16:57: End Shadow Rects 1
2017-06-03 00:16:57: End Shadow Rects 2
2017-06-03 00:16:57: LOADING MAP: Calculating Lighting


And here's more info about my setup:
Code:
$ inxi -Fx
System:    Host: manjaro Kernel: 4.4.70-1-MANJARO x86_64 (64 bit gcc: 6.3.1)
           Desktop: KDE Plasma 5.9.5 (Qt 5.8.0) Distro: Manjaro Linux
Machine:   Device: laptop System: ASUSTeK product: K53SD v: 1.0
           Mobo: ASUSTeK model: K53SD v: 1.0
           BIOS: American Megatrends v: K53SD.204 date: 01/17/2012
Battery    BAT0: charge: 33.0 Wh 100.2% condition: 32.9/59.4 Wh (55%)
           model: ASUSTek K53--54 status: N/A
CPU:       Quad core Intel Core i7-2670QM (-HT-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 17567
           clock speeds: max: 3100 MHz 1: 978 MHz 2: 1465 MHz
           3: 1499 MHz 4: 1384 MHz 5: 1570 MHz 6: 808 MHz 7: 1202 MHz
           8: 1103 MHz
Graphics:  Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           bus-ID: 00:02.0
           Card-2: NVIDIA GF119M [GeForce 610M] bus-ID: 01:00.0
           Display Server: X.Org 1.19.3 driver: intel
           Resolution: 1366x768@60.02hz
           GLX Renderer: Mesa DRI Intel Sandybridge Mobile
           GLX Version: 3.0 Mesa 17.1.1 Direct Rendering: Yes
Audio:     Card Intel 6 Series/C200 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: ALSA v: k4.4.70-1-MANJARO
Network:   Card-1: Intel Centrino Wireless-N 100
           driver: iwlwifi bus-ID: 03:00.0
           IF: wlp3s0 state: up mac: 78:92:9c:8b:64:10
           Card-2: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet
           driver: atl1c v: 1.0.1.1-NAPI port: 9000 bus-ID: 05:00.0
           IF: enp5s0 state: down mac: c8:60:00:44:9a:6e
Drives:    HDD Total Size: 500.1GB (40.3% used)
           ID-1: /dev/sda model: ST9500325AS size: 500.1GB
Partition: ID-1: / size: 95G used: 84G (94%) fs: ext4 dev: /dev/sda5
           ID-2: swap-1 size: 4.63GB used: 0.38GB (8%) fs: swap dev: /dev/sda6
Sensors:   System Temperatures: cpu: 54.0C mobo: N/A
           Fan Speeds (in rpm): cpu: 2400
Info:      Processes: 234 Uptime: 2:32 Memory: 3607.4/5749.0MB
           Init: systemd Gcc sys: 6.3.1
           Client: Shell (fish) inxi: 2.3.8


Attachments:
Screenshot_20170603_001753.png
Screenshot_20170603_001753.png [ 860.32 KiB | Viewed 163 times ]
Top
 Profile  
Reply with quote  
 Post subject: Re: Stuck on calculating lights on linux demo
PostPosted: Sat 03 Jun 2017, 02:53 
Gobbling Turkey
User avatar

Joined: Fri 11 Apr 2014, 03:26
Posts: 177
Location: Florida
Gender: Male
There is a known issue with linux lighting, try going to the options and setting lighting quality to 0, then load a map and see if it works. Not sure if smoothing needs to be off as well.

_________________
DISCLAIMER; Thoust hereith claim I grammer and spelling to be of that which is not of or in but as with above most yet least excellent sarcastic. Not yours, my. IE; dibs.

I do have a life. I'm just trying really hard to not have one.


Top
 Profile  
Reply with quote  
 Post subject: Re: Stuck on calculating lights on linux demo
PostPosted: Sun 04 Jun 2017, 23:56 
Geneshift Creator
User avatar

Joined: Sat 14 Mar 2009, 17:50
Posts: 6019
Location: Sydney, Australia
Gender: Male
Hey man, welcome to the forums :) I am aware of this bug in Linux and will try fix this. Until then, set the "Lighting Quality" to 0 and that should fix it.

_________________
Creator of Geneshift and Nik Nak Studios. Hope you enjoy the game!


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 1   [ 3 posts ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron